Pi-hole showing zero clients, zero ads blocked yet pihole -t shows active connections


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Pi hole should show more than zero clients connected and show connections being blocked.

Actual Behaviour:

Zero clients are listed in the web interface though pihole -t shows connections streaming live as expected, however pihole -c -j shows {“domains_being_blocked”:122154,“dns_queries_today”:0,“ads_blocked_today”:0,“ads_percentage_today”:0.000000}. This went unnoticed several weeks after running a pihole -up. Running pihole -up now shows that I’m currently up to date.

Debug Token:

6k0n9oc3rg


#2

Are you running Jessie on your system? If so, please have a look at the posts I link herein. The problem is that Jessie has a too old version of dnsmasq which we cannot support any longer.

There are basically four things you can do:

Or update your system to the most recent version (Stretch)


#3

I am running Stretch with Dnsmasq version 2.76.

pi@astro:~ $ lsb_release -a     
No LSB modules are available.   
Distributor ID: Raspbian        
Description:    Raspbian GNU/Linux 9.4 (stretch)                
Release:        9.4             
Codename:       stretch         
pi@astro:~ $ dnsmasq --version
Dnsmasq version 2.76  Copyright (c) 2000-2016 Simon Kelley
Compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth     DNSSEC loop-detect inotify

This software comes with ABSOLUTELY NO WARRANTY.
Dnsmasq is free software, and you are welcome to redistribute it
under the terms of the GNU General Public License, version 2 or 3.
pi@astro:~ $

#4

Make a new debug token.


#5

5otehn0rf2


#6

Run pihole -r to repair. Dnsmasq wasn’t configured to use the “extra” logging format, so FTL was unable to parse the log correctly.


#7

That seems to have fixed it! Thank you so much for your help!