Problems with new install


#1

I have just made a fresh install of PiHole on a pi3

Although I can logon to the admin page, nothing is working.

Ads are not being blocked and if I click on the query log I get the error below.

An unknown error occured while loading the data.


Fatal error: Uncaught Error: Call to undefined function json_encode() in /var/www/html/admin/api.php:100
Stack trace:
#0 {main}
thrown in /var/www/html/admin/api.php on line 100

Also the dashboard just has spinning arrows.

Debug token is wspj97el11

I have also tried reinstalling twice.

Thanks
Bob


#2

Run pihole -d for a new debug token. I was on vacation for a while and just got back on Discourse.


#3

Sorry, I missed the cutoff time as well. Let us know the new token and we can take a look.


#4

OK, I’ll set it up again. I reverted to an old version as that worked OK. I also found that the new version would run perfectly OK on a Pi 2 model B


#5

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.