Pi-hole v4.0 Released With FTLDNS, Improved Blocking Modes, Regex, Docker, and More

v4-0

#21

I understand - and agree with - the reasoning behind. But I am concerned with being “locked out” from updates on one blocklist by an other blocklist.

I changed my gravity.sh and inserted:

if [ dig $domain +short | grep 0.0.0.0 -c -ge 1 ]; then
ip=dig @1.1.1.1 +short $domain
if [ echo $url | awk -F '://' '{print $1}' = “https” ]; then
port=443;
else port=80
fi
echo -e “${OVER} ${CROSS} ${str} ${domain} is currently blocked by pi-hole. Circumventing pi-hole and trying again”;
echo -ne " ${INFO} ${str} Pending…"
cmd_ext="–resolve $domain:$port:$ip $cmd_ext"
fi

Just before:

httpCode=$(curl -s -L ${cmd_ext} ${heisenbergCompensator} -w “%{http_code}” -A “${agent}” “${url}” -o “${patternBuffer}” 2> /dev/null)

My blocklists now update even if the URL is blocked by pi-hole:

$ pihole -g
[i] Neutrino emissions detected…
[✓] Pulling blocklist source list into range

[i] Target: hosts-file.net (grm.txt)
[✗] Status: hosts-file.net is currently blocked by pi-hole. Circumventing pi-hole and trying again
[✓] Status: Retrieval successful

[i] Target: reddestdream.github.io (minimalhosts)
[✓] Status: No changes detected

[i] Target: raw.githubusercontent.com (hosts)
[✓] Status: Retrieval successful


#22

Quick question : Are there any limitations to running Pi-hole v4.0 when it comes to the used Debian/RaspBian version ?

In other words :
Can I safely upgrade version 3.3.1 running on Raspbian Jessie like I mentioned here => Unexpected version of dnsmasq on Raspbian Jessie
to the latest version of Pi-Hole ?

Thanks in advance :slight_smile:


#23

Yes V4.0 is safe to run on Jessie. Make sure you are on the master branch by using pihole checkout master


X-Header does not match or could not be retrieved in debug log
Pihole not showing index.php blockpage
#24

Hello,

I used the iptable fix for the “endless loading time issue” with the last pi hole version and updated today to version 4.

Have I to do anything to remove this no longer needed fix or does the new update erase it automatically?

Greetings


#25
iptables -L --line-numbers

will show you the ones.

Then you can use

iptables -D <CHAIN> <LINE NUMBER>

to delete them.


#26

Perfect. It worked fine. Thank you very much!

Marginal note: you have to be a super user to do this.


#27

Guys… you didn’t lie : Version 4.0 is a INSANE FAST ad blocking BEAST!!! :smiley:

Thank you & Keep up the good work! :sunglasses: :+1:t2::+1:t2:


#28

I tried the pihole -up command and it updated the Core without any problems. However when trying to update the FTL, I get

[i] FTL Checks...
[i] Downloading and Installing FTL...curl: (22) The requested URL returned error: 404 Not Found
[✗] Downloading and Installing FTL

Any ideas what I’m doing wrong? Thanks in advance!


#29

This has been a problem for some. The solution for many has been to change the local name server for Pi-Hole to a 3rd party DNS, then run the update.

sudo nano /etc/resolv.conf and change 127.0.0.1 to a commercial DNS (1.1.1.1 will work). Save and exit.

Then rerun pihole -up

If the update is successful, the resolv.conf file will change back to 127.0.0.1.


#30

Thanks for your help. I tried exactly what you said, but I’m still getting the same exact error. I’m completely ignorant so any other thoughts would be helpful.


#31

Edit resolv.conf the same way, but then run pihole -r instead of pihole -up. Select the “repair” option.


#32

I had this problem indeed, but noticed the issue immediately so it was a quick fix that didn’t really bother me :slight_smile:


#33