Install a more recent dnsmasq on Raspbian Jessie



Update: 2018-08-06

As of v4.0, Pi-hole ships with _FTL_DNS, our fork of dnsmasq, which should restore compatibility with Raspbian Jessie. We still recommend installing a newer OS as Jessie is EOL anyway.

Please note that this tutorial is only meant for Rasbian Jessie, although it might (to some extend) also help with similar issues on other Debian versions. Do this at your own risk (however, the likeliness of a failure is rather small in our opinion).

First step: Download more recent version of dnsmasq compiled for Raspbian Jessie from the official sources


Second step: Ensure requirements are fulfilled

sudo apt-get install libnetfilter-conntrack3 libmnl0

Third step: Install downloaded packages

sudo dpkg -i dnsmasq-base_2.76-5+rpi1_armhf.deb
sudo dpkg -i dnsmasq_2.76-5+rpi1_all.deb

Fourth step: Verify it worked:

dnsmasq -v

should return:

Dnsmasq version 2.76  Copyright (c) 2000-2016 Simon Kelley
Compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify

You should now be able to use Pi-hole v3.3 on Raspbian Jessie.

Pi-hole v3.3 Released: It's "Extra" Special
FTL 3.0 fails to restart on Raspbian Jesse
Seit Update auf 3.2 geht nichts mehr :(
Query Log Wont Populate
Issues after latest update
Dnsmasq startet nicht - Grund 01-pihole.conf -> log-queries=extra | Token zgpnrjzunw
Can't update from 3.2.1 to latest version
Web interface showing no stats
FTL issue on new install
Pihole not blocking ads in adlists.list
Pi-hole showing zero clients, zero ads blocked yet pihole -t shows active connections
So Long Pihole
Pi-hole only briefly works after reboot
Services won’t start after upgrade
Pihole Start up Issues
Dnsmasq Service Failing - PiHole not working
Update Failed - Please contact pihole
Issue installing pihole
Unable to use pihole on raspbian 8
Empty /etc/pihole after re install
403 - Forbidden after install
PiHole configured as DNS + DHCP and has internet access, but no traffic logged in web console
Raspbian jessie issues, not logging, no graphs, have to restart ftl service
Raspbian jessie issues, not logging, no graphs, have to restart ftl service
DNS and FTL not running
New install of 3.3 doesn't seem to be actually filtereing
Admin page returns 403 Forbidden; new install
Installation stopped
Why can't I run Pi-hole v3.3+ on Raspbian Jessie or with dnsmasq < v2.72?
Frustrating fresh pihole installation, no internet
Issue with DNSMasq
Install Pi-hole on UniFi Cloud-Key : problem with install
Fresh install, DNS/FTP not running/offline
DNS service is not running on pi hole
No data in query log
pihole-FTL 3.0 fails to start on Raspbian Jessie reboot
Dnsmasq not starting since last week!
Pihole GUI not updating stats
Issue with dashboard and blocking ads
Webinterface not reachable
Dnsmasq startet nicht - Grund 01-pihole.conf -> log-queries=extra | Token zgpnrjzunw


Thanks a lot, worked here :slight_smile:


Thx, working great on my odroid-jessie (Odroid c1 with Debian jessie for c1) Pi hole v 3.3 is running without any issues now (i had to downgrade before)


Sadly it does not update on my Synology NAS DS-413j (seems indeed to be this “Jessie”-thingie)

dnsmasq stays at 2.72


This fix is only intended for Raspbian Jessie.


2 posts were split to a new topic: Update of dnsmasq failed


Any fix for synology?


These instructions are specific to Rasbpian Jessie. We don’t have anything for Synology at this time. Feel free to check out the FTLDNS beta, which should actually work better than the version you may be on now with the issues.


i wonder why it is not already included in the armhf repo from Debian.
Repo for raspbian, for example, includes an up-to-date version of dnsmasq


It’s just the Debian way of doing things.

On their current stable “stretch” and obsolete (but supported) “jessie” releases, security issues are addressed as they come up, but the feature-set remains pretty well as constant as can be maintained for the life of the release. Security patches are ported back to older versions of software, fixing any problems but not adding any new features.

For people who want newer features, the testing release “sid” is generally quite robust, but is not stable in the sense that new features are added along the way.

For people who don’t mind probable breakage from time to time, there is also the unstable release “testing”, with constant updates and new features.


I guess i have to update orange pi following similar procedure as somebody did here

Thanks for your answer


is there any update for ubuntu 16.04 xenial as how to manually upgrade dnsmasq to a version that supports log-queries=extra?

pihole-FTL 3.0 fails to start on Raspbian Jessie reboot

After this manual update, the dnsmasq service is now starting automatically and the only thing pending was having pihole-FTL starting automatically on system reboot, which for some reason was not happening.

I had to run the following command after each reboot

sudo service pihole-FTL

I read on another post (lost link) that reinstalling pihole fixed the issue.

to uninstall

pihole uninstall

to install

curl -sSL | bash

Now pihole-FTL service starts automatically after system reboot.