FTLDNS looses connwction to API

ftldns

#1

After some hours after activating FTLDNS Pihole Armin shows “Lost Connection to API”
and “FTL offline”
I will switch back to original version but created an token beforehand:

Your debug token is: 3hl02cewe7

Can someone help?
Thanks


#2

It seems like dnsmasq wasn’t disabled and still occupied port 53 so FTLDNS failed to start. If you want to try it again and it does fail again, try

sudo service dnsmasq stop
sudo service pihole-FTL restart

#3

Thanks. I did not completely understand: does this mean I first start FTLDNS as I did before and then immedeately run the two commands you mentioned? Until now I tried FTLDNS about 5 times and it always stopped working after some hours. But it seemed to work at the beginning.


#4

Oh, I’m sorry, I misread your post. When it fails, what are the most recent lines in /var/log/pihole.log and /var/log/pihole-FTL.log?


#5

Herr the first log:

May 15 21:17:02 dnsmasq[1887]: exiting on receipt of SIGTERM
May 15 21:17:04 dnsmasq[3437]: started, version 2.76 cachesize 10000
May 15 21:17:04 dnsmasq[3437]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify
May 15 21:17:04 dnsmasq[3437]: warning: ignoring resolv-file flag because no-resolv is set
May 15 21:17:04 dnsmasq[3437]: using nameserver 213.73.91.35#53
May 15 21:17:04 dnsmasq[3437]: using nameserver 208.67.222.222#53
May 15 21:17:04 dnsmasq[3437]: read /etc/hosts - 2 addresses
May 15 21:17:04 dnsmasq[3437]: read /etc/pihole/local.list - 4 addresses
May 15 21:17:04 dnsmasq[3437]: read /etc/pihole/black.list - 0 addresses
May 15 21:17:04 dnsmasq[3437]: bad address at /etc/pihole/gravity.list line 2
May 15 21:17:04 dnsmasq[3437]: bad address at /etc/pihole/gravity.list line 3
May 15 21:17:04 dnsmasq[3437]: bad address at /etc/pihole/gravity.list line 4
May 15 21:17:04 dnsmasq[3437]: bad address at /etc/pihole/gravity.list line 5
May 15 21:17:04 dnsmasq[3437]: bad address at /etc/pihole/gravity.list line 6


#6

Now the second, hope it helps:

[2018-05-15 21:35:31.023] ########## FTL started! ##########
[2018-05-15 21:35:31.023] FTL branch: FTLDNS
[2018-05-15 21:35:31.023] FTL version:
[2018-05-15 21:35:31.023] FTL commit: fa0045e
[2018-05-15 21:35:31.023] FTL date: 2018-05-12 15:43:49 -0400
[2018-05-15 21:35:31.023] FTL user: pihole
[2018-05-15 21:35:31.023] Notice: Found no readable FTL config file
[2018-05-15 21:35:31.023] Using default settings
[2018-05-15 21:35:31.024] Starting config file parsing (/etc/pihole/pihole-FTL.conf)
[2018-05-15 21:35:31.024] SOCKET_LISTENING: only local
[2018-05-15 21:35:31.024] AAAA_QUERY_ANALYSIS: Show AAAA queries
[2018-05-15 21:35:31.024] MAXDBDAYS: max age for stored queries is 365 days
[2018-05-15 21:35:31.024] RESOLVE_IPV6: Resolve IPv6 addresses
[2018-05-15 21:35:31.024] RESOLVE_IPV4: Resolve IPv4 addresses
[2018-05-15 21:35:31.024] DBINTERVAL: saving to DB file every minute
[2018-05-15 21:35:31.024] DBFILE: Using /etc/pihole/pihole-FTL.db
[2018-05-15 21:35:31.024] MAXLOGAGE: Importing up to 24.0 hours of log data
[2018-05-15 21:35:31.024] PRIVACYLEVEL: Set to 0
[2018-05-15 21:35:31.024] IGNORE_LOCALHOST: Show queries from localhost
[2018-05-15 21:35:31.024] BLOCKINGMODE: Pi-hole’s IP for blocked domains


#7

what’s the output of

cat /etc/pihole/gravity.list | sed 6q


#8

The timestamps in the two logs you posted don’t match (they’re almost 20min apart from each other).

Which operating system and device do you try running FTLDNS on? Do you use DNSSEC?

Also:

  • Your FTLDNS version is already a few days old, please try pihole -up
  • Is your second log complete, i.e. is BLOCKINGMODE: Pi-hole’s IP for blocked domains the last line in your log?..