DHCP Server Trouble


#22

From the terminal on your Mac, you can find the Pi-Hole on the network by name or by IP only?

dig pi.hole

ping -c5 pi.hole

ping -c5 192.168.1.201


#23

It appears by IP only…

dig returns:

; <<>> DiG 9.10.6 <<>> pi.hole
;; global options: +cmd
;; connection timed out; no servers could be reached 

ping -c5 pi.hole returns:

ping: cannot resolve pi.hole: Unknown host

ping -c5 192.168.1.201 returns:

PING 192.168.1.201 (192.168.1.201): 56 data bytes
64 bytes from 192.168.1.201: icmp_seq=0 ttl=64 time=6.302 ms
64 bytes from 192.168.1.201: icmp_seq=1 ttl=64 time=0.250 ms
64 bytes from 192.168.1.201: icmp_seq=2 ttl=64 time=0.365 ms
64 bytes from 192.168.1.201: icmp_seq=3 ttl=64 time=0.361 ms
64 bytes from 192.168.1.201: icmp_seq=4 ttl=64 time=0.332 ms

--- 192.168.1.201 ping statistics ---

5 packets transmitted, 5 packets received, 0.0% packet loss

round-trip min/avg/max/stddev = 0.250/1.522/6.302/2.390 ms

#24

What is the output of this command from the Mac terminal (not ssh’d into the Pi). This will tell the order of the DNS resolvers that the Mac is using.

scutil --dns


#25
scutil --dns
DNS configuration

resolver #1
  search domain[0] : fios-router.home
  nameserver[0] : 192.168.1.201
  flags    : Request A records
  reach    : 0x00020002 (Reachable,Directly Reachable Address)

resolver #2
  domain   : local
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300000

resolver #3
  domain   : 254.169.in-addr.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300200

resolver #4
  domain   : 8.e.f.ip6.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300400

resolver #5
  domain   : 9.e.f.ip6.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300600

resolver #6
  domain   : a.e.f.ip6.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 300800

resolver #7
  domain   : b.e.f.ip6.arpa
  options  : mdns
  timeout  : 5
  flags    : Request A records
  reach    : 0x00000000 (Not Reachable)
  order    : 301000

DNS configuration (for scoped queries)

resolver #1
  search domain[0] : fios-router.home
  nameserver[0] : 192.168.1.201
  if_index : 8 (en0)
  flags    : Scoped, Request A records
  reach    : 0x00020002 (Reachable,Directly Reachable Address)

#26

I will also just add that I keep having to disable the custom DNS as I am unable to do any of the following when it is enabled:

  • Load images on this page
  • Play a radio station in iTunes
  • Receive images in text messages/iMessages
  • Load pi-hole.net
  • Load pi-hole.net ad test pages

Not sure if that is helpful information or not, but wanted to include it in case it helps with troubleshooting for you @jfb


#27

Even though you have the DNS of the Pi-Hole specified in the Mac, and the Pi-Hole appears to be working properly, the Pi-Hole isn’t resolving your DNS requests. The only thing between the Mac and Pi-Hole is the router, so I’d look there. Take a bit and go through all the settings in the router following your manual, and see if any of the DNS or DHCP settings are causing this. I don’t have that model router and can’t see the screens, so it’s a bit of a research project for you.


#28

Yeah I have looked through it pretty extensively, and haven’t found much. I have tried enabling and disabling DHCPs and setting the DNS as well, I have a feeling it is just such a ‘consumer level device’ that it doesn’t allow it and is blocking it somewhere either in terms or ports or firewalls, but I just don’t even know where to look… Any specific ideas of things to check that might be causing this?


#29

The manual for this router uses different terminology than most routers, but check for dynamic DNS (don’t want that), DNS prebinding (don’t want that), family friendly or filtered DNS (don’t want that), and if you don’t use IPv6, turn that off on the router as well.


#30

Confirmed that it is all off, and went through and verified router settings. Everything should work:

Broadband:

Network:


#31

I’m not familiar with that router and can’t offer much help. It would be worth a call to FIOS tech support.


#32

Turns out the fix was super simple…

sudo ufw disable


#33

Turns out there was an additional component to this.

In terminal, sudo ufw disable showed the issue I was having being the firewall basic settings.

In case anyone else comes across this topic, the final fix was as follows:

sudo ufw disable
sudo ufw allow 67
sudo ufw allow 68
sudo ufw allow 53
sudo ufw allow 80
sudo ufw enable 

That corrected the issue and appears to open the affected ports.


#34

Where did you make these changes - terminal on which device?


#35

Terminal on the pi-hole device.


#36

Did you install ufw or did it come with your OS distribution?


#37

I believe it came with, but I honestly don’t remember.