Curl: (6) Could not resolve host: install.pi-hole.net


#1

pi@raspberrypi:~ $ curl -sSL https://install.pi-hole.net | bash
curl: (6) Could not resolve host: install.pi-hole.net

on


Raspbian Stretch with desktop
Image with desktop based on Debian Stretch
Version: November 2017
Release date: 2017-11-29
Kernel version: 4.9

pi@raspberrypi:~ $ cat /etc/resolv.conf

Generated by resolvconf

nameserver 192.168.1781

after each reboot resolv.conf is overwritten… so editing no good idea… should be .1 at the end of ip address for nameserver, or another problem?


#2

Check at bottom of below file to see if any “static domain_name_servers” configured ?

sudo nano /etc/dhcpcd.conf

If you make changes, check again after reboot with cat /etc/resolv.conf.


#3

Raspbian Stretch with Desktop has compatibility issues that you will have to work around in order to get the Pi-hole working. I would suggest the Raspbian Stretch Lite package instead.


#4

installed

Raspbian Stretch Lite
Minimal image based on Debian Stretch
Version: November 2017
Release date: 2017-11-29
Kernel version: 4.9
Release notes: Link

with diskimager on sdram,
added ssh file without extension to boot files…
connected using putty ssh… port 22
but get:
software caused connection abort…
found:


exported reg key with ip, deleted reg key, tried again, no connection…
imported reg key again…
any suggestions?


#5

Can you ping the IP of the new Stretch install? Does https://www.raspberrypi.org/forums/viewtopic.php?t=191252 provide any clues?


#6

yes for sure, its pingable… will check that link.
…not helps that much, reason:

ssh is not enabled by default. As mentioned in this thread you need to put the SD card back into your PC and create an empty file with the name ssh or ssh.txt and put it in the root level of the card. (the only folder you can see in Windows). Now put the SD back into the RPi. If successful the ssh will be enabled and the ssh file will be deleted.

–>> done, ssh file is deleted after trying to reach via ssh putty to raspberry pi using ip shown in fritz.box and
named by nslookup to ip… for raspberry pi
and i am connected via ethernet directly to fritzbox 7490… dhcp…
ip shown in home network area of box

bernd


#7

… after new imaging sd card with Debian Stretch i was able to install pi hole…

  • where can i test it on which webpages if its working?
  • i added the ip of the pi with pi hole installed on as my local dns server to give to clients in dns config in fritzbox
  • how could i maybe change dns upstream server from a google dns server to another one?
    thx for help again
  • i told pi hole to use a static ip in inital setup dialog… what is the difference between setting it manually via
    sudo nano /etc/dhcpcd.conf
    and add there sth like:

Konfiguration feste IP-Adresse

interface eth0
static ip_address=192.168.178.100/24
static routers=192.168.178.1
static domain_name_servers=192.168.178.1


#8

No difference except maybe Pi-hole will configure domain_name_servers to be 127.0.0.1 on the loopback interface.