Cant update FTL


#1

debug token : fqrgzl2p1o

I just install pihole on raspbian in hyper v but now i saw that the ftl service was offline so i google it and i easy fix was update pihole so i try to do that but every time i try to update ill get a error see debug
how can i fix this ?


#3

can you run pihole -r and select repair?

You are actually missing the pihole-FTL binary :slight_smile:
Repair should take care of that.


#4

21

still geting the same error :frowning:


#5

try running the same repair command from the user pi not from root.

does which pihole-FTL output a path ?


#6

yes it has a path /usr/bin/pihole-FTL

and i did try to repair pihole from the user but still getting the same error


#7

What is the output of sudo systemctl status pihole-FTL.service ?


#8

i hope this is enough i dont know how to see more


#9

That looks good. pihole-FTL is runing.

How is your admin interface looking?


#10

4
i just did a restart now i get this when i do it

and me admin panel look like this know


#11

Try removing pihole and reinstalling from scratch. (install it from the user not from root).


#12

look like it’s not working still new token key 5oxsv35vk5


#13

i did install pihole now on ubuntu 18 it looks like everything is working i did update pihole with pihole -up

but still the ftl service is not running and when i run the command service i see [+] iphole-FTL so i guess the service is running


#14

this one is solved just needed to restart the service


#15

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.